TechSupport Forum

Go Back   Perfect World > Technical Assistance > Network and Connection Problems
Login

Notices

 
 
Thread Tools Display Modes
Tech Support User
Join Date: May 2013
Posts: 2
# 1 Raiderz Invalid ID or Password
05-12-2013, 10:45 AM
Hey,

I downloaded Raiderz yesterday to try it since I saw a video and thought it was pretty awesome but i can't log in.

The game gives me "invalid ID or password" message. I'm trying to log in using the same account i'm using to write this post, and play neverwinter, which works fine. Tried changing the password, making a new account, changing server regions, etc...

Please help me, I'm really interested in playing Raiderz.
Tech Support User
Join Date: May 2013
Posts: 2
# 2 RaiderZ invalid ID or Password
05-12-2013, 10:48 AM
Hey,

I downloaded Raiderz yesterday to try it since I saw a video and thought it was pretty awesome but i can't log in.

The game gives me "invalid ID or password" message. I'm trying to log in using the same account i'm using to write this post, and play neverwinter, which works fine. Tried changing the password, making a new account, changing server regions, etc...

Please help me, I'm really interested in playing Raiderz.
Tech Support Machine
Join Date: Jul 2008
Posts: 2,358
# 3
05-12-2013, 10:48 AM
Your password should have ONLY English letters and numbers in it. No spaces, no special characters at all. You can change your password to be 10-14 characters max.

Some games do not accept some special characters for passwords, even though the website account page does.

Please check the spelling and capitalization.

Try using your account name to sign in with or your email address, instead of your nick name/alias.

Please note: RDZ, BLR, and RH require you to sign in with your account name and will not accept the email address as the login. If you do not know your account name, contact customer support.

If you still need help, send a ticket to customer support
Tech Support User
Join Date: May 2013
Posts: 1
# 4
05-22-2013, 09:10 PM
Would love to contact support, but when I try to go to the support link, I get an internet error saying "loop" LOL. Having login issues is a good way to discourage potential customers.
Tech Support User
Join Date: Jun 2012
Posts: 189
# 5
05-23-2013, 12:25 AM
customerservice@perfectworld.com

There's also a stickied thread at the top of "Forum and Website Issues" that explains the redirect problem. Unfortunately it's only affecting certain accounts and it's being a royal pain for the tech team to pin down a cause and fix.
Tech Support User
Join Date: Jun 2013
Posts: 1
# 6
06-30-2013, 10:01 PM
Hello I am also having the same problem mentioned above ID and password invalid, logava normal until then more from the last update started to get so I ask you to help me solve this problem.
Tech Support User
Join Date: Oct 2013
Posts: 1
# 7
10-03-2013, 07:58 AM
I've tried logging in with my neverwinter info as well, and it won't let me in. Can post on forums, log into neverwinter, etc...nothing with RaiderZ. What gives guys, why doesn't it link? I'm not making a new account every time I want to play a different game, I'll just take my money somewhere else.
Tech Support User
Join Date: Jul 2013
Posts: 2
# 8
10-08-2013, 09:02 PM
So.. can i use my PW or Neverwinter account? Cus so far it just gives me wrong login id or password. Do i have to register a seperate login for RaiderZ?
Tech Support User
Join Date: Jan 2014
Posts: 1
# 9 same here
01-26-2014, 09:11 AM
hey folks
just wanted to say that i get the same message, dont know if anyone of you made any progress yet - i've sent a ticket, but from what i've read there'll probably be just some "make a new account" proposal.
user name and pw work on the website and the last game i played
both words are lowercase

well ... i just think this is a stupid problem - i mean what's the problem in adding a game on perfect world and then making the user name and pw work to login ... doesnt sound like some fancy programming to me.
ah man ... whatever. hopefully see y'all ingame

ps.
i just changed the pw again and avoided using "y" - i know z and y are switched in eng und ger layout and although i tried both keys to login, no use - but now without the y it works!
the game crashed after logging in - so i had to use low quality settings first and change the graphics ingame - i guess "shadows" is what caused the crash, cant get it past normal or some error will occur.

Last edited by pitsha; 01-26-2014 at 11:24 AM.
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -7. The time now is 10:26 PM.